查看: 594|回复: 2

[转载软件/工具] IDA 安装keypatch和findcrypt-yara插件

[复制链接]

8

主题

27

帖子

0

精华

初级会员

Rank: 4

学币
70
荣耀
0
rank
0
违规
0

    发表于 2019-9-12 17:45:54 | 显示全部楼层 |阅读模式
    本帖最后由 zhangziyu 于 2019-9-12 20:46 编辑

    Keypatch 可以直接修改二进制代码的插件
    安装:
    1、 下载Keypatch.py复制到插件目录
    IDA \plugins\Keypatch.py
    2、 下载安装keystone python模块,64位系统只需要安装这一个就行

    然后你就能发现在IDA里的Edit->Keypatch


    findcrypt-yara 找加密方式的插件
    简介:IDA pro plugin to find crypto constants (and more)
    安装:
    1、 安装yara-python,最简单的方式是使用:pip install yara-python
    2、 下载findcrypt.py复制到插件目录
    IDA \plugins\findcrypt3.rules
    IDA \plugins\findcrypt3.py

    然后你就能发现在IDA里的Edit->plugins->findcrypt
    原文链接https://www.cnblogs.com/zhaijiahui/p/7978897.html
    温馨提示:
    1.如果您喜欢这篇帖子,请给作者点赞评分,点赞会增加帖子的热度,评分会给作者加学币。(评分不会扣掉您的积分,系统每天都会重置您的评分额度)。
    2.回复帖子不仅是对作者的最好奖励,还可以获得学币奖励,请尊重作者的劳动成果,拒绝做伸手党!
    3.发广告、灌水回复等违规行为一经发现直接禁言,如果本帖内容涉嫌违规,请点击论坛底部的举报反馈按钮,也可以在【投诉建议】板块发帖举报。

    4

    主题

    20

    帖子

    0

    精华

    初级会员

    Rank: 4

    学币
    45
    荣耀
    0
    rank
    150
    违规
    0

      发表于 2019-9-14 16:40:47 | 显示全部楼层
      我先去试一下

      4

      主题

      20

      帖子

      0

      精华

      初级会员

      Rank: 4

      学币
      45
      荣耀
      0
      rank
      150
      违规
      0

        发表于 2019-9-14 16:42:39 | 显示全部楼层
        突然想起来自己的python好像是3.7的。。。7.0是支持2.7的吗
        快速回复 返回顶部 返回列表